„Posts von Freunden Plugin“ nach Update von WordPress defekt

Updaten auf WP 2.2 (Notiz 1: friends-rss.php)

Wenn ihr das PlugIn „Friends RSS Aggregator“ von adam404 bei euch am Laufen habt und auf WordPress 2.2 updatet (was durchaus sinnvoll ist), dann habt ihr wahrscheinlich auch wieder massive Probleme, was euer wp-admin Backend betrifft. (Keine neuen eingehenden Links werden angezeigt, links im Admin Menu steht lediglich so etwas wie:
Cannot redeclare class magpierss … /wp-includes/rss-functions.php on line 14?…

Dann helfen alle Tips soweit nichts, ausser in der wp-admin/index-extra.php die folgende Zeile wie folgt auszukommentieren:
//require_once (ABSPATH . WPINC . ‚/rss.php‘);

Dann klappts auch mit dem netten Backend!

Grund ist eine Inkompatibilität des von Word Press beigelegten MagpieRSS mit der Version von Adam und die neue Änderung der wp-includes/rss.php und der wp-includes/rss-functions.php.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.