Windows Vista USB Massenspeicher Probleme

Wenn man unter Windows XP einen USB Speicher Stick an den Rechner steckt dauert es kurz und man findet kurz danach im Explorer auch schon ein neues Laufwerk, welche den USB Stick angibt.
OK, unter Vista erwartet man das ja gar nicht mehr, weil man „wegen der Sicherheit“ ja in Kauf nimmt, dass man 2-10 Bestätigungen treffen muss um dem Administrator klar zu machen, dass man auch mal auf seinen Speicherstab zugreifen möchte.
Doch Probleme bekommt man obendrein, da jeder Stick irgendwie einzeln hinzugefügt wird und Vista sich anscheinend auch nicht merken kann, wo seine Standarttreiber liegen. Also TIP 1: immer eine Suche nach dem Treiber auf dem ganzen Laufwerk (mit Unterordnern) starten und dann klappt es meistens.

Nicht klappen wird es allerdings, wenn sich einmal die Installation irgendwie zerlegt hat. Dann steckt man den USB Stick ein und es wird, egal wie man es handhabt, kein passender Treiber dafür gefunden. Entschuldigungen, die ungef. wie folgt lauten: „Ein unbekanntes Gerät wurde erfolgreich installiert. Das Gerät ist nicht einsatzbereit“ sind da nicht selten.
Es gibt Leute im Netz, die meinen, es reiche, wenn man die Date c:windowsinfINFCACHE.1 löscht. (Hat bei mir nix genützt!)

Ich habe endlich eine Lösung gefunden:
Die Dateien usbstor.inf und usbstor.PNF ausfindig machen (meistens liegen die nämlich nur noch in c:windowssystem32 und sind irgendwie von dort aus nicht mehr installierbar (jedenfalls entdeckt die Treibersuche diese dort nicht, obwohl man Unterordner mit einbezieht)) und diese ganz einfach in den Ordner c:windowsinf kopieren. Beim nächsten Start und Verwendung eines Speichermediums gehts dann ganz leicht, wenn man auf der Platte sucht oder ganz einfach in c:windows mit Unterordnern.

(Ich habe übrigens nicht nur die beiden Dateien kopiert, sondern auch noch ein paar andere, weil „wegen der Sicherheit“ und Laufruhe :-))
Viel Erfolg, falls euch auch das Problem genervt hat. (Lange Suchen nach Mainboardtreibern, USB Unterstützung – neuen Treibern, … hat da nämlich nix gebracht)

NACHTRAG:
Man kann übrigens, um das ganze zu optimieren dann in der Systemsteuerung/System/Erweiterte Systemeinstellungen/Hardware das ganze Prozedere des ewigen Onlinesuchens (falls man dieses irgend wann einmal als erste Quelle eingestellt hatte) hier wieder zurück stellen.
VistaDriverUpdate
Von „Automatisch nach Treibern suchen“ auf z.B. „Jedes Mal nachfragen“ – Sehr angenehm!

————————————–
Eine geniale Anleitung Grafikkartentreiber gerade für Notebooks, die nicht als originaler nVidia Chip erkannt werden (z.B. für die GeForce 7400) zu installieren findet man übrigens hier
Also wenn ihr bei der Installation die Meldung bekommt: „Das NVIDIA Setup-Programm konnte keine Treiber finden, die mit der aktuellen Hardware kompatibel sind“ ist dies vermutlich DIE LÖSUNG!

21 thoughts on “Windows Vista USB Massenspeicher Probleme”

  1. Hab das selbe Problem, habe zwar den Treiber gefunden und installiert aber sobald ich den Stick abziehe und dann wieder draufstecke, will er erneut einen Treiber haben. Und dann kommt die Geschichte mal sagt er unbekanntes Gerät, dann neues Laufwerk, dann USB Stick und am ende ein Massenspeichergerät. DELL hat gemeint ich soll den Laptop platt machen und Vista neu aufspielen Bring das was???
    Btte, ich verzweilfle sonst noch!!!!

  2. DANKE! THANK YOU! MERCI! ich steckte schon in einem tiefen taal der verzweifelung, da ich mit meinem neuen notebook weder usbstick, noch ipod verwenden konnte, da fand ich diesen tollen tip hier und schon klappte alles….

    VISTA IST EINFACH NUR ZUM KOTZEN

  3. oh man, ich hab echt ewigkeiten gesucht und endlich die lösung gefunden.
    danke danke
    ganz schön peinlich…hoffe mal, dass bald ein servicepack kommt in dem sowas behoben wird

  4. Vielen Dank, hab echt das ganze Internet durch stöbert und bin zum Glück hier gelandet. Das Problem ist im Net nicht sehr verbreitet, was es noch schwieriger macht es zu beheben. Vielen Dank jetzt klappt alles wieder!!!

  5. Und was mach ich wenn diese beiden Dateien komplett vom System verschwunden sind? Sie befinden sich weder im inf ordner noch im system32 ordner, noch sonst irgendwo auf meinen partitionen.
    Hab langsam echt die Schnauze voll von Vista und den Usb-problemen die ich seit nunmehr 5 monaten habe… Irgendein Update hats mir denk ich mal versaut… Vorher angeschlossene USB Geräte funktionieren tadellos, aber auch nur an dem USB Port an dem sie ursprünglich angeschlossen waren. (PSP bsp. funktioniert nur an einem Port, bei jedem weiteren will er Treiber haben)

  6. Hallo, klasse Tipp ! Ich habe Vista 64bit und eine HDDrive2go (Medion) und nach vielen vergeblichen Versuchen jetzt nach einfachem Kopieren der USBSTOR* Dateien in windows/inf, das LW endlich sofort verfügbar! Vielen Dank !!!

  7. hallo
    die lösung liegt also nahe,aber wo finde ich diese dateien ?? ich hab versucht die auf der original vista cd mit „suchen“ zu finden aber anscheind bin ich zu blöde.
    kann mir mal jemand sagen in welchem ordner die zu finden sind ??
    danke

  8. Hm, bei mir liegen beide angegebenen Dateiein bereits in dem Ordner windows/inf vor…
    Und was jetzt???? Er zeigt mir immer an „unbekanntes Gerät“ gefunden. Wenn ich versuche, dieTreiber zu aktualisieren, sagt er mir „Die Teibersorftware für dieses Gerät ist auf dem neueste Stand“.

    Hat jemand noch eine Idee???
    Danke

  9. Sorry, ich muß leider feststellen, das das bei mir überhaupt nichts bringt.
    1. Das Problem tritt bei mir nur in Verbindung mit USB-Stick bis 1GB auf!
    2. Die besagten Treiber sind bei mir in dem Ordner INF
    3. Selbst nach kopieren dieser Dateien zusätzlich in den Ordner System32, keine änderung

    Also wenn mir da jemand mal ne Lösung geben kann, wäre ich echt zu tiefstem Dank verpflichtet!!

    Zusatzinfos:
    Hier funzen nur alle Sticks ab 1GB
    – Windows Vista Ultimate 32
    – SP1
    Hier funzen selbst Sticks(Wechselkarten von der Digicam mit 16MB)
    – Windows XP Professional
    – SP3

    Vista macht mir eh noch echt Kummer! Habe es seit 3 Monaten drauf und habe schon etliche Graue Haare deswegen!!!

    🙁

  10. Danke man endlich funkt die scheisse jetzt. Ich hab fast die kriese gekriegt, früher war das nich so, alles hatte perfekt geklappt, aber in letzter zeit steck ich meine USB Festplatte ein und will was drauf installieren oder eine große datei rein kopieren dann ging die Festplatte aufeinmal einfach so verloren ohne das ich den kabel raus nehme. Aber nich nur die Festplatte, auch die MP3 player usw. Und irgendwann kam der hammer nämlich das mein IDE DVD Brenner aufeinmal DVD´s und CD´s manchmal nich brennen konnte oder Lesen. Je nach seiner laune, Mal hat der die gleiche Medium gelesen mal nich. Der Brenner is nich futsch weil sie auf nem anderen rechner perfekt funkt. Als ersatz hab ich sogar nen Externes DVD laufwerk angeschlossen selbst der machte probleme -.- aber jetzt scheint sie auch zu gehen. Nur mein IDE DVD Brenner hab ich noch nicht ausgetestet weil ich sie auf mein altes PC angeschlossen habe nachdem mich die ganze sache angekotzt hatte weil er jede menge Rohlinge verschwendet hat auf mein normales PC. xD muss ich noch mal schaun. Danke nochmals für den Tip. Vista is schon geil und so aber Ist echt ganz schön nervig manchmal

  11. Das wirkt wohl auch nicht mehr…

    Also bei mir hat das Problem gänzlich aufgehört nach einer Neuinstallation mit allen Updates und natürlich den entsprechenden Treibern.

    Also mit Vista SP 2 ist dann alles bei mir ohne Probleme gelaufen.

  12. Meine externe Festplatte, die zwei Jahre lief und fast voll ist (80 GB von Trekstor) wird von meinen Computer nicht mehr erkannt – arbeite mit Vista. Habe die Tipps alle durchgeführt aber es klappt trotzdem nicht, was kann ich tun. Viele Grüße Kerstin

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.